The error message “The update is not applicable to your computer” has a most likely very simple explanation – you are trying to use the wrong platform installer. I have seen this error when trying to update PowerShell to 5.1 in a Windows Server 2012 R2.

 

The solution is very simple: check your Windows version from control panel or Settings and make sure you download the installer corresponding to your Windows version. Good luck!